Committed to connecting the world

  •  

ITU-T work programme

Home : ITU-T Home : ITU-T Work Programme : H.741.2     
  ITU-T A.5 justification information for referenced document W3C XML Schema Part 2 (2001) in draft H.741.2
1. Clear description of the referenced document:
Name: W3C XML Schema Part 2 (2001)
Title: XML Schema Part 2: Data types
2. Status of approval:
Approved by W3C as Recommendation on 2 May 2001.
3. Justification for the specific reference:
This standard is well-known as XML schema definition for several data types. Several parts of this standard is also applicable to audience measurement metadata definition by using of XML schema.
4. Current information, if any, about IPR issues:
W3C is a Royalty Free organization. An on-line identification of patent policy is available at the following URL: http://www.w3.org/2004/01/pp-impl/
5. Other useful information describing the "Quality" of the document:
The status of all the referred specifications is "approved specification".
6. The degree of stability or maturity of the document:
The status of all the referred specifications is "approved specification". A 2nd edition exists (2004), http://www.w3.org/TR/2004/PER-xmlschema-2-20040318/. Lateste version: http://www.w3.org/TR/xmlschema-2/.
7. Relationship with other existing or emerging documents:
References within the referenced specifications are listed under item (8).
8. Any explicit references within that referenced document should also be listed:
Normative/
Clinger, WD (1990) /
William D Clinger. How to Read Floating Point Numbers Accurately. In Proceedings of Conference on Programming Language Design and Implementation, pages 92-101. Available at: ftp://ftp.ccs.neu.edu/pub/people/will/howtoread.ps /
IEEE 754-1985 /
IEEE. IEEE Standard for Binary Floating-Point Arithmetic. See http://standards.ieee.org/reading/ieee/std_public/description/busarch/754-1985_desc.html /
Namespaces in XML /
World Wide Web Consortium. Namespaces in XML. Available at: http://www.w3.org/TR/1999/REC-xml-names-19990114/ /
RFC 1766 /
H. Alvestrand, ed. RFC 1766: Tags for the Identification of Languages 1995. Available at: http://www.ietf.org/rfc/rfc1766.txt /
RFC 2045 /
N. Freed and N. Borenstein. RFC 2045: Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies. 1996. Available at: http://www.ietf.org/rfc/rfc2045.txt /
RFC 2396 /
Tim Berners-Lee, et. al. RFC 2396: Uniform Resource Identifiers (URI): Generic Syntax.. 1998. Available at: http://www.ietf.org/rfc/rfc2396.txt /
RFC 2732 /
RFC 2732: Format for Literal IPv6 Addresses in URL's. 1999. Available at: http://www.ietf.org/rfc/rfc2732.txt /
Unicode Database /
The Unicode Consortium. The Unicode Character Database. Available at: http://www.unicode.org/Public/3.1-Update/UnicodeCharacterDatabase-3.1.0.html /
XML 1.0 (Second Edition) /
World Wide Web Consortium. Extensible Markup Language (XML) 1.0, Second Edition. Available at: http://www.w3.org/TR/2000/WD-xml-2e-20000814 /
XML Linking Language /
World Wide Web Consortium. XML Linking Language (XLink). Available at: http://www.w3.org/TR/2000/PR-xlink-20001220/ /
XML Schema Part 1: Structures /
XML Schema Part 1: Structures. Available at: http://www.w3.org/TR/2001/REC-xmlschema-1-20010502/ /
XML Schema Requirements /
World Wide Web Consortium. XML Schema Requirements. Available at: http://www.w3.org/TR/1999/NOTE-xml-schema-req-19990215 /
Non-normative/
Character Model /
Martin J. Dürst and François Yergeau, eds. Character Model for the World Wide Web. World Wide Web Consortium Working Draft. 2001. Available at: http://www.w3.org/TR/2001/WD-charmod-20010126/ /
Gay, DM (1990) /
David M. Gay. Correctly Rounded Binary-Decimal and Decimal-Binary Conversions. AT&T Bell Laboratories Numerical Analysis Manuscript 90-10, November 1990. Available at: http://cm.bell-labs.com/cm/cs/doc/90/4-10.ps.gz /
HTML 4.01 /
World Wide Web Consortium. Hypertext Markup Language, version 4.01. Available at: http://www.w3.org/TR/1999/REC-html401-19991224/ /
IETF INTERNET-DRAFT: IRIs /
L. Masinter and M. Durst. Internationalized Resource Identifiers 2001. Available at: http://www.ietf.org/internet-drafts/draft-masinter-url-i18n-07.txt /
International Earth Rotation Service (IERS) /
International Earth Rotation Service (IERS). See http://maia.usno.navy.mil /
ISO 11404 /
ISO (International Organization for Standardization). Language-independent Datatypes. See http://www.iso.ch/cate/d19346.html /
ISO 8601 /
ISO (International Organization for Standardization). Representations of dates and times, 1988-06-15. Available at: http://www.iso.ch/markete/8601.pdf /
ISO 8601 Draft Revision /
ISO (International Organization for Standardization). Representations of dates and times, draft revision, 2000. /
Perl /
The Perl Programming Language. See http://www.perl.com/pub/language/info/software.html /
RDF Schema /
World Wide Web Consortium. RDF Schema Specification. Available at: http://www.w3.org/TR/2000/CR-rdf-schema-20000327/ /
Ruby /
World Wide Web Consortium. Ruby Annotation. Available at: http://www.w3.org/TR/2001/WD-ruby-20010216/ /
SQL /
ISO (International Organization for Standardization). ISO/IEC 9075-2:1999, Information technology --- Database languages --- SQL --- Part 2: Foundation (SQL/Foundation). [Geneva]: International Organization for Standardization, 1999. See http://www.iso.ch/cate/d26197.html /
U.S. Naval Observatory Time Service Department /
Information about Leap Seconds Available at: http://tycho.usno.navy.mil/leapsec.990505.html /
Unicode Regular Expression Guidelines /
Mark Davis. Unicode Regular Expression Guidelines, 1988. Available at: http://www.unicode.org/unicode/reports/tr18/ /
XML Schema Language: Part 2 Primer /
World Wide Web Consortium. XML Schema Language: Part 2 Primer. Available at: http://www.w3.org/TR/2001/REC-xmlschema-0-20010502/ /
XSL /
World Wide Web Consortium. Extensible Stylesheet Language (XSL). Available at: http://www.w3.org/TR/2000/CR-xsl-20001121/ /
9. Qualification of W3C:
W3C is qualified for including references in ITU-T Recommendations under Recommendation A.5 procedures.
10. Other (for any supplementary information):
All standards are available on-line. An index of Recommendation and their status may be found in the W3C archives at http://www.w3.org/TR/ .
Note: This form is based on Recommendation ITU-T A.5